CCNA 指令速查表

前言

這份速查表是在暨南資工唸書時,有門 CCNA 的課程,由張瑛杰老師開設,手把手教我們設定。

由於是兩年前的筆記了,現在才想到要做紀錄,可能會有些錯誤還請指正。

題外話

Juniper 的機器好處是下錯指令,還有還原的機制,印象中似乎是一分鐘後會自動還原原本設定。而 Cisco 機器則是指令下了就執行了,因此下錯就得趕緊手動回復原先的設定,這時候最怕忘記原先設定是啥,或是忘了原本指令怎麼下。

三種模式

  1. usermode
    • enable 指令可以跳下一種模式,縮寫為 en
  2. # 特權模式
    • show running-config 可以查看目前設定
    • configure terminal 可跳到下一種模式,縮寫為 conf t
  3. Conf

常用指令

  • # write:將 running-config 寫到 startup-config,縮寫為 wri
  • (conf)# hostname:顯示 hostname,第一個字元必須為字母,最長 64 個字元
  • Ctrl + Shift + 6:強制終止,在莫名其妙卡住時很有效!

設定 console 密碼

(conf)# line console 0
(conf)# password 你的密碼
(conf)# login

設定 enable 密碼

(conf)# enable password 你的密碼   // 這邊將以明文儲存,如不放心可以用下一行的指令
(conf)# enable secret 你的密碼     // 這會將密碼做雜湊後儲存
(conf)# no enable password         // 取消 password 密碼
(conf)# no enable secret           // 取消 secret 密碼

設定 vlan

(conf)# interface vlan 1
(conf)# no shutdown                // 因為預設是 shutdown
(conf)# ip address 192.168.1.1 255.255.255.0

列出 vlan

vlan 是群組,interface vlan 是對外的只能有一個有 IP Address,用來遠端連線登入設定 switch 用,跨網段需設定 default static route。

# show vlan

或是

(conf)# do show vlan

設定 telnet 密碼

(conf)# line vty 0 4               // 總共允許 5 台連線
(conf)# password 你的密碼
(conf)# login

將明文密碼加密

(conf)# service password-encryption // 啟用
(conf)# no password-encryption      // 禁用

告警訊息

印象中原廠有說,不要使用挑釁字眼。

(conf)# banner motd "Don't try"

小筆記

在 show run 中沒看到下面參數不代表沒有,若是預設就可以不用輸入

int fa 0/1
switchport
switchport mode access
switchport access vlan 1

IPv6

(conf)# interface GigabitEthernet 0/0
(conf)# ipv6 address FE80::1 link-local
(conf)# ipv6 address <addr>/<netmask>
(conf)# ipv6 enable
(conf)# exit
# ipv6 unicast-routing
(conf)# ip default-getway <ip addr>

trunk

(conf)# int fa 0/1
(conf)# switchport mode trunk
(conf)# switchport trunk allow vlan 10,20,30

一些我現在看不懂的

# vlan 10
# show ip route
將 router 關機,插上 HWIC-2T module
# ip route <destination> <netmask> <IP Address / interface>  // 下四行是舉例
# ip route 192.168.3.0 255.255.255.0 192.168.5.2             // 這是 static route
# ip route 192.168.3.0 255.255.255.0 serial 0/3/0
# ip route 0.0.0.0     0.0.0.0       192.168.5.1             // 這是 default static route
# ip route 192.168.3.0 255.255.255.0 serial 0/3/0
# ipv6 route 2001:D8::1/64 2001:D20::2
# ipv6 route 2001:D8::10 2001:D10::2
# ipv6 route 2001:D8::10 serial 0/3/0

float 權重

# ipv6 route 2001:D8::10 serial 0/3/0 5

RIPv2 設定(Router 身上所有的 interface 都要寫進去)

(conf)# route rip
(conf)# versino 2
(conf)# no auto-summary           // 不上 router 自動合併路由
(conf)# network 163.22.4.0
(conf)# network 163.22.5.0
(conf)# passive-interface gi 0/0  // 不將 route 資訊送到非 router 的 interface
(conf)# exit
# ip route 0.0.0.0 0.0.0.0 ge 0/0
# route rip
# default-information originate

comments powered by Disqus